1 Reply Latest reply on Jul 17, 2012 1:42 PM by historicalshavlikemployee

    Could not read the remote registry: Error 5: Access is denied.

    Master
      I am trying to install the agent on a workgroup computer from a domain computer and keep getting, "Could not read the remote registry: Error 5: Access is denied."  I am using the correct credentials on the machine, <computer><user> but it will not connect.  What am I missing?  The user name is an administrator on the workgroup machine and I verified the Administrators group has Full Control permissions to the HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSecurePipeServerswinreg.  The workgroup machine is Windows 7 Professional.

      Thanks,
      Ron
        • 1. Re: Could not read the remote registry: Error 5: Access is denied.
          Master
          You can confirm that you are able to adequately access the target as follows:

          1) Verify the credentials with which you are currently logged into the console machine.

          2) Using the Windows Registry Editor, attempt to connect to the target (e.g. the agent machine in question) registry.

          3) Once connected to the target registry, verify that you are able to successfully browse both of the connected hives.

          If you are still unable to connect to the target registry, confirm that the 'Remote Registry' service is started, and that you have correctly configured the machine for remote registry access. Of particular note is the following (taken from our administration guide, also found via the 'Help>Index' menu):

               For machines using Windows operating systems that employ the use of User Account Control (this includes Windows Vista or later and Windows Server 2008 or later), you must either:

               Join the machines to a domain and then use domain administrator credentials. If you are not using the built-in Administrator account on the remote machines (and using that account is NOT recommended), you must disable User Account Control (UAC) remote restrictions on the machines. To do this:

               1. Click Start, click Run, type regedit, and then press Enter.
               2. Locate and then click the following registry subkey:

               HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionPoliciesSystem

               3. If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps:

               a. On the Edit menu, point to New, and then click DWORD Value.
               b. Type LocalAccountTokenFilterPolicy and then press Enter.

               4.Right-click LocalAccountTokenFilterPolicy and then click OK.
               5.In the Value data box, type 1, and then click OK.
               6.Exit Registry Editor.

               For more details on disabling UAC remote restrictions, see http://support.microsoft.com/kb/951016