4 Replies Latest reply on Sep 15, 2011 8:45 PM by historicalshavlikcustomer

    Error - SERVERNAME: '': parameter name: 'encoded'

    Master
      I keep getting the above error when I push to ONE server in our environment.  I have a feeling I'm missing something really simple in this, but it just keeps eluding me... I have tried completely removing all references to Shavlik from the server in question and repushing, but it still happens...

      I am using NetChk Protect version 7.8.0, Build 1388.  The machine being pushed to is a normal Windows 2003 server, with nothing really special on it...
        • 1. Re: Error - SERVERNAME: '': parameter name: 'encoded'
          Master
          Try the following:

          Create a new machine group, and add only the machine in question. Be sure to specify appropriate credentials for the machine in the lower pane of the machine group.

          Scan the machine with the 'Security Patch Scan' template.

          Once the scan is complete, select a single patch (preferably an operating system patch), then choose to deploy the patch using the 'Standard' deployment template (please keep in mind that this template includes a post-deployment reboot).

          Were you able to successfully complete the steps above? If not, at what point did you recieve an error (please be as precise as possible)?
          • 2. Re: Error - SERVERNAME: '': parameter name: 'encoded'
            Master

            I am able to scan the machine fine, and when I start the deployment, I get the following:

            SERVERNAME: Connecting
            SERVERNAME: Copying file: WindowsServer2003-KB941569.exe
            SERVERNAME: File complete: WindowsServer2003-KB941569.exe
            SERVERNAME: File exists qchain.exe
            SERVERNAME: File exists cl5.exe
            SERVERNAME: File exists safereboot.exe
            SERVERNAME: File exists safereboot64.exe
            SERVERNAME: Copying file: 2011.09.15-07.55.25-SHAVLIKSERVER-SERVERNAME.bat
            SERVERNAME: File complete: 2011.09.15-07.55.25-SHAVLIKSERVER-SERVERNAME.bat
            SERVERNAME: Copying file: 2011.09.15-07.55.25-SHAVLIKSERVER-SERVERNAME.cfg
            SERVERNAME: File complete: 2011.09.15-07.55.25-SHAVLIKSERVER-SERVERNAME.cfg
            SERVERNAME: File exists winhttp.dll
            SERVERNAME: Initiating the task
            Error - SERVERNAME: '': parameter name: 'encoded'
            Deployment complete, finishing process...
            Deployment complete

            Any information you can give me is appreciated.

            • 3. Re: Error - SERVERNAME: '': parameter name: 'encoded'
              Master

              Can you try manually rebuilding the scheduler service on the target machine (I am assuming that you are using the Shavlik Scheduler service with the default port of TCP 5120), then re-trying a deployment?

              Complete these steps on the target machine on which you wish to remove the scheduler:
              1) From a command prompt, browse to the 'c:windowspropatchesscheduler' directory.

              2) Execute the following command:

              'stschedex /remove'

              3) Delete the 'c:windowspropatches' directory.

              4) Delete the following registry key(s) (if they exist):

              32 bit - 'HKEY_LOCAL_MACHINESOFTWAREShavlikScheduler'
              64 bit - 'HKEY_LOCAL_MACHINESOFTWAREWow6432NodeShavlikScheduler'

              5) Validate the 'Shavlik Remote Scheduler Service' isn't listed as a service.

              6) Power-cycle the machine (if this is possible).

              7) The scheduler service should be automatically re-installed at the next deployment.
               

              • 4. Re: Error - SERVERNAME: '': parameter name: 'encoded'
                Master
                Manually recreating the Scheduler service appears to have resolved my issues.  Thank you for the assistance!!