4 Replies Latest reply on Mar 1, 2011 10:05 PM by historicalshavlikcustomer

    7.6 won't deploy win7 sp1, says see log.

    Master
       Trying to deploy win7sp1, shavlik just says "No patches were deployed, see the program logs".  What program logs?  could it be more vague?


        • 1. Re: 7.6 won't deploy win7 sp1, says see log.
          Master


          Greetings,


          Are you trying to deploy all missing patches, or are you specifically selecting the Windows 7 Service Pack 1 for deployment?  Why I ask, deploying all missing patches does not deploy any Service Packs.  Service Packs have to be deployed separately and individually.

          Is the Service Pack showing as downloaded?  It is a large ~900MB download.  You might want to download it before your deployment to make sure the download completes successfully.

          The logs it is referring to can be found here:
             -Vista, 2008,  & Win7: C:ProgramDataShavlik TechnologiesLogs
             -Windows XP & 2003: C:Documents and SettingsAll UsersApplication DataShavlik TechnologiesLogs

          Unless the logging level was set to "All" or "Verbose", the logs may not have all the pertinent information to troubleshoot the issue.  The level of logging is set under  Tools > Options > Logging.  Please note:  You do not want to leave your logging level set this way permanently though, as it does add unnecessary overhead on the console.

          To gather full logs for support, please complete these steps:

          In NetChk go to Tools > Options > Logging and make sure both User Interface and Services are set to “Verbose”.  Click on Save.  Click Restart Now if prompted.
          - Close NetChk.
          - Stop all the Shavlik services.
          - Delete all the logs from:
             -Vista, 2008,  & Win7: C:ProgramDataShavlik TechnologiesLogs
             -Windows XP & 2003: C:Documents and SettingsAll UsersApplication DataShavlik TechnologiesLogs
          -Start the Shavlik services and open NetChk.
          -Run the process again that generates the error or failure.  In your case, attempt to deploy Windows 7 SP1.
          -Afterwards please zip up and send all the logs back to us at support@shavlik.com and reference this forum post.
          -Set your logging level back to Informational.  Anything else is just excessive overhead on the console.


          Thanks!

          • 2. Re: 7.6 won't deploy win7 sp1, says see log.
            Master
             Download was not available as an option until I stopped netchk and services to delete log files and switch loggin to ALL.  I have done these steps and I am now downloading the SP.

            I was just attempting to push win7sp1 only to a single machine.

            I'll post more and send logs when the download completes and I attempt the push again.

            -Jeff
            • 3. Re: 7.6 won't deploy win7 sp1, says see log.
              Master
              Greetings Jeff,


              I believe you uncovered the problem during your further troubleshooting.  The patch was showing available, but not downloadable.  This is most likely why your deployment failed.

              This happens from time to time after an XML upgrade.  If you would have closed NetChk and restarted the Shavlik NetChk Console Service, and then went back into NetChk, you would then of had the option to download the Service Pack.  Sorry about the inconvenience (this bug is being looking into on this end).

              I do not anticipate you will have any problems with the deployment this time.  If you do, please let us know.


              Thanks!




              • 4. Re: 7.6 won't deploy win7 sp1, says see log.
                Master

                 Now that the services have restarted the problem has gone away.  

                Thanks for letting me know how to get the logs though!

                -Jeff