2 Replies Latest reply on Dec 29, 2010 12:18 PM by historicalshavlikemployee

    SCUPdates Firefox and Thunderbird behavior change

    Master
      Starting with the SCUPdates file released on 04/23/2010, customers may notice 3 behavioral changes in the way we detect Firefox and Thunderbird patches. 

      First, prior to this release we would detect a version of Firefox or Thunderbird as missing if that version was not installed.  This meant that if a customer has any version of the Firefox 3.0, 3.5, or 3.6 product line installed, the customer would be able to install any version of Firefox 3.0, 3.5, or 3.6 by approving the appropriate update in SCCM.  Thunderbird detection behaves similarly.  Starting with this release, we will no longer show older versions of Firefox or Thunderbird as applicable.

      For instance, consider the scenario where a target machine has Firefox 3.6.2 installed, and there are deployments created and approved for Firefox 3.6.1 and Firefox 3.6.3.  When looking at the results of a software updates inventory, customers will only see Firefox 3.6.3 as missing.  Firefox 3.6.1 will no longer show as missing.

      Second, we will now only upgrade Firefox and Thunderbird along the currently installed product lines.  Installations of Firefox 3.0 will now only show other versions of Firefox 3.0 as missing.  Installations of Firefox 3.5 will now only show other versions of Firefox 3.5 as missing.  Installations of Firefox 3.6 will now only show other versions of Firefox 3.6 as missing.  Thunderbird detection will behave similarly.

      For instance, consider the scenario where a target machine has Firefox 3.0.18 installed.  Only Firefox 3.0.19 will show as missing.  Firefox 3.5.x and Firefox 3.6.x updates will not show as missing on the target machine.

      When a version of Firefox or Thunderbird no longer receives security updates, we will at that time add in support to upgrade versions of Firefox and Thunderbird outside of product lines.

      Finally, we will now only upgrade Firefox and Thunderbird with the proper language installer.  Previously, we would install the English language version on any target machine.  We currently only support detecting and installing the English version of Firefox and Thunderbird.

      Thanks!

      --jace