2 Replies Latest reply on Apr 12, 2018 10:13 AM by DaveLum

    Scheduled tasks show as having run, but did not

    DaveLum Rookie

      I have an Ivanti Patch for Windows console that used to work flawlessly - including scheduled scans - until I also tried to install Ivanti Patch for Linux on the same server (now removed).

       

      The symptom is viewing scheduled console tasks they show as having executed, but when looking at results, nothing has been scanned and the reports don't get emailed.

       

      This link refers to reinstalling the scheduler serviceHow to Re-Install Scheduler Service on Shavlik Protect Console Server. but under managed scheduled console tasks there is no way to Right-click the target machine name in the list on the left, and click Scheduler Service > install

       

      I did try the resolution steps anyway, but that did not resolve the issue

        • 1. Re: Scheduled tasks show as having run, but did not
          treed SupportEmployee

          Hi,

           

          The only difference between a scheduled task and a manual one is that we put a task on the Windows Task Scheduler to kick of the scan at a certain time. All other process are the same. Most likely the Task Scheduler is not kicking off the scan or permissions aren't allowing it to. I would suggest opening an admin command prompt on your Ivanti Patch for Windows server and typing the command "whoami".  Go to Manage > Scheduled Console Tasks and select "Set scheduler credential" and click "New". Create or Recreate the credential using the user who you are currently logged into with (the whoami user). Once done remake a task and test.

           

          For additional information I would also suggest reviewing this guide on why we test this: Console Scheduler Credential - The Selected Console Scheduler Credentials Does Not Match The Current User's Account. Please Enter A Shared Credential Matching The Current Account.

           

          I hope this helps.

           

          Thanks,

          Troy

          • 2. Re: Scheduled tasks show as having run, but did not
            DaveLum Rookie

            Ok I tried this. The Ivanti console says the task ran successfully, and Windows Task scheduler also says the task runs successfully (0x0), but if I go to machine view the last scan patch date timestamp does not change nor do I get the emailed results.

             

            The exact same scan works fine sans the scheduler, it's as if there's something about what the task scheduler is calling that's broken. I have another Ivanti console that works fine (it scans different systems on a different domain), and comparing what I see in the console and task scheduler on the two, I see no apparent difference. Runs under SYSTEM account, whether user is logged on or not, action is Custom Handler, and all other settings on the task tabs are the same.

             

            I did try uninstalling / reinstalling Patch for Windows but, not surprisingly it did not change anything.

            Out of curiosity I created a simple reboot task in the Windows Task Scheduler to make sure the scheduler worked in some fashion, and that works. Even setting that task to be executed by the SYSTEM account works.

             

            Is there a way to view the custom handler properties?