7 Replies Latest reply on Jun 4, 2017 8:20 PM by daniel.mclaughlan

    Java and Adobe DC Upgrades/Patches

    shanew Employee

      Hi Guys

       

      I have a client who is trying to upgrade/patch the following using Shavlik Patch: 2.3

       

      Java 7 40  to Java 8 131

       

      and

       

      Adobe Reader DC 15 020.20039 to DC 17.009.20044

       

      in both case the error code is error= 0x80240022.

       

      Question, is the version change in both of the above too much, should they try going to an earlier Java 8 or DC 17 version, or is there some other pre req missing.

       

      Any help greatly appreciated.

       

      Regards

       

      Shane

        • 1. Re: Java and Adobe DC Upgrades/Patches
          cwinning CommunityTeam

          Shane,

           

          The Content Team will require some debug information to determine what is happening.  Are you able to create a case on this and give me the case number?

           

          They will require the following:

           

           

          Thank you,

          Charles

          • 2. Re: Java and Adobe DC Upgrades/Patches
            shanew Employee

            Thanks for the response Charles.

             

            My questions was is it possible to upgrade from the versions listed or not. - absolutely happy to open a case if there isanother issue, but can the customer do this upgrade.

             

            Thanks

             

            Shane

            • 3. Re: Java and Adobe DC Upgrades/Patches
              cwinning CommunityTeam

              Hello,

               

              Thanks for the clarification.  My upgrade from Adobe Reader DC 15.007.20033 directly to 17.009.20044 was successful.  What happens when you manually install on one of these failure machines?

               

              You could upgrade Java 7 40. Our JAVA7U8-131 patch would remove Java 7 first, then install Java 8u131 for you.

               

              Thanks,

              Charles

               

              • 4. Re: Java and Adobe DC Upgrades/Patches
                daniel.mclaughlan Rookie

                Hi Charles,

                 

                I have engaged Shane's assistance thorugh our support channels on this issues. I am currently testing Shavlik integrated with SCCM and have got the certificate working (I'v been able to deploy Flash 25 to machines with Flash 24).

                 

                When trying to deploy Adobe Reader 17.009.20044, upgrading from Reader 15.020.20039 my clients instantly fail with a 0x8024002D error in the Software Center. Integrroagting the WUAHandler.log returns:

                 

                Installation job encountered some failures. Error = 0x80240022.      WUAHandler   11/05/2017 11:11:09 AM        228 (0x00E4)

                The whole excerpt is:

                Going to search using WSUS update source. WUAHandler   11/05/2017 11:10:23 AM        720 (0x02D0)

                Synchronous searching of all updates started... WUAHandler   11/05/2017 11:10:23 AM        720 (0x02D0)

                Successfully completed synchronous searching of updates. WUAHandler   11/05/2017 11:10:57 AM        720 (0x02D0)

                1. 1. Update: ff2ee134-3ca2-4136-bc72-d91af4211b53, 1   BundledUpdates: 0          WUAHandler 11/05/2017 11:10:58 AM   720 (0x02D0)
                2. 1. Update (Missing): Adobe Acrobat Reader DC 17.009.20044 (ff2ee134-3ca2-4136-bc72-d91af4211b53, 1)            WUAHandler 11/05/2017 11:10:58 AM        720 (0x02D0)

                Async installation of updates started. WUAHandler   11/05/2017 11:10:59 AM        720 (0x02D0)

                Update 1 (ff2ee134-3ca2-4136-bc72-d91af4211b53) finished installing (0x8024002d), Reboot Required? No WUAHandler   11/05/2017 11:11:09 AM        3488 (0x0DA0)

                Async install completed. WUAHandler   11/05/2017 11:11:09 AM        3488 (0x0DA0)

                Installation job encountered some failures. Error = 0x80240022.      WUAHandler   11/05/2017 11:11:09 AM        228 (0x00E4)

                Installation of updates completed.      WUAHandler 11/05/2017 11:11:09 AM        228 (0x00E4)

                 

                  With the Reader, I can find the source files in the ccmcache:
                RDRDC.png
                If I extract the MSP file from that CAB File and run it, I get the following prompt:

                RDRDC_1.png

                 

                So i believe this is either a configuration error in our environment or an issue with the package?
                I believe had this issue previously when I hadn't properly patched the MSP file with the DC 15 base installer.

                 

                 

                Regarding our clients for Java update, we had an urgent requirement to upgrade java to 8U131 so I scripted a package for this. Unfortuantely i am not able to extract the registry key, as all active workstations are now running 8U131.
                What i found is that Java7U40 clients simply did not trigger the requirement for the Java upgrade. The package was pushed but no clients 'required' it.

                 

                Thanks for your assistance.
                Daniel.

                • 5. Re: Java and Adobe DC Upgrades/Patches
                  cwinning CommunityTeam

                  Hello,

                   

                  For your Adobe Reader DC issue, we don't repackage the actual executable used for the update it's directly from the vendor. Your test would indicate an issue in your environment. A quick google search for that error code, a lot of people are seeing it if they have Windows Defender/Security Essentials enabled.  At the very least, it should install by hand and if not, there is something blocking you.

                   

                  For the Java issue, I can't comment on your custom package.  It's odd though, JAVA7U8-131 should show required if the target is running Java7U40.  I would suggest running our diagnostic scanning tool and run a scan against one of these machines.  It will tell us what is installed and what can be installed on it.  Once we know what is detected missing, you can publish it and attempt to push to it and see where you stand after that. 

                   

                  You can run the tool remotely or on the client, just use defaults and enter your address and account information:

                   

                  DPDTrace GUI Tool: Used to troubleshoot patch detection issues

                   

                  Thanks,

                  Charles

                  • 6. Re: Java and Adobe DC Upgrades/Patches
                    daniel.mclaughlan Rookie

                    Any idea on where to reach out for support on our current configuration of Adobe?

                     

                    EventVwr:
                    Product: Adobe Acrobat Reader DC - Update 'Adobe Acrobat Reader DC

                    (17.009.20044)' could not be installed. Error code 1603. Additional information is available in the log file C:\Users\DANIEL~1\AppData\Local\Temp\MSIa5506.LOG.


                    Log above:

                     

                    DEBUG: Error 2746:  Transform TGT_11ToUPG_11 invalid for package C:\Windows\Installer\313ec.msi. Expected product {AC76BA86-7AD7-1046-7B44-AC0F074E4100}, found product {AC76BA86-7AD7-1033-7B44-AC0F074E4100}.

                     

                    So it appears as though the MSI installed on my systems is not confgured correctly as you mentioned, based on the MSI product codes above.

                     

                     

                     

                     

                     

                    DEBUG: Error 2746:  Transform TGT_11ToUPG_11 invalid for package C:\Windows\Installer\313ec.msi. Expected product {AC76BA86-7AD7-1046-7B44-AC0F074E4100}, found product {AC76BA86-7AD7-1033-7B44-AC0F074E4100}.

                    1 of 1 people found this helpful
                    • 7. Re: Java and Adobe DC Upgrades/Patches
                      daniel.mclaughlan Rookie

                      Have run the Reader Cleanup Utility (Download Adobe Reader and Acrobat Cleaner Tool - Adobe Labs ) , done a fresh re-install of DC 15 and can now update to 17.x

                       

                      Next steps for me are to re-modify the base installer with our customizations, Run the cleanup across my fleet, re-roll re-packaged DC 15 and then patch to 17.
                      Would love to know what went wrong in the first place, given that that's the process we initially followed last year when building our images! >_>

                      1 of 1 people found this helpful