1 Reply Latest reply on Mar 17, 2017 6:22 AM by anthony.swanson

    Deployment Template - Issue with Custom Action

    PatchWerk Rookie

      I'm having issues setting up a Custom Action in a Deployment Template.

      I've used the instructions in this thread as a guideline: Deployment Template - custom actions - where do I put the .bat file 

       

      The only difference in my setup compared to the above mentioned guide is that I seem to be pushing patches to C:\ProgramData\LANDESK\Shavlik Protect\Agent\Patch\PatchData instead of C:\Windows\ProPatches\.

       

      For testing purposes I've created a small .bat file that writes a value to the registry.

      test.bat:

      reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Test" /v Test /t REG_SZ /d Test

       

      I've set up a deployment template with the custom actions:

      1: push file - path\to\patches\test.bat

      2: After all patches - call %PATHTOFIXES%test.bat

       

      Patch Scan Template:

       

      I would assume that the result of this would be that every time I deploy a patch with the test-template, test.bat will be pushed to the server, and then executed.

      But this isn't the case. When I run a patch scan that deploys a custom patch with my test-template the custom action isn't pushed to the server, or executed.

      I'm not able to find "test.bat" mentioned in any of the logs.

       

      Any help would be appreciated.

       

      I've got a central distribution server and a number of servers with agents:

      Server: Shavlik Protect Standard 9.2.0 Build 5119

      Agent: Shavlik Protect Agent 9.2.9 Build 5149

       

      //