1 2 Previous Next 15 Replies Latest reply on May 26, 2016 7:11 AM by croth2

    7-Zip 16.00 x64 fails to install

    croth2 Apprentice


      - 7-Zip 16.00 x64 is failing to install
      - Tried it after reboot as well and still failing on my machine
      - Went to source files and copied out the CAB
      - - Source:  \\sccm\Sources\UpdatePkgs\Shavlik_Third-Party_Updates\2d61284a-1f0d-4c83-be53-2901c80a1e91\
      - - Copied:  afe290fb-8ae7-4491-adbd-44dee7e1d3e4_1.cab
      - Extracted the MSI inside the cab
      - - File:  7z1600-x64.msi

      - Went to:  http://www.7-zip.org/download.html 
      - Downloaded the MSI:  http://www.7-zip.org/a/7z1600-x64.msi
      - - File:  7z1600-x64.msi

      - Did a file hash comparison and they are IDENTICAL
      - Ran the installer manually with:

       

      msiexec /i 7z1600-x64.msi /qb

       

      - I was prompted that "Windows Explorer" needed to be closed, with options:
      - - Automatically close and attempt to reopen
      - - Don't close and a reboot will be needed
      - Cancelled installer and tried:

       

      msiexec /i 7z1600-x64.msi /qb

       

      - This appears to use the close Windows Explorer option and I am not prompted, but Explorer didn't reopen
      - I had to do so via command line "explorer.exe"

       

      My previous version was the Shavlik update "7-Zip 15.14 x64".  Anyone else having this issue?

        • 1. Re: 7-Zip 16.00 x64 fails to install
          Rookie

          I am just testing this update and it has not installed to any of my test workstations either. Like you, we are currently on 15.14 x64.

          • 2. Re: 7-Zip 16.00 x64 fails to install
            croth2 Apprentice

            Shavlik folks, sounds like this update may have an issue.  Your results?

            • 3. Re: 7-Zip 16.00 x64 fails to install
              cwinning CommunityTeam

              Hello,

               

              We've seen the same issue with Shavlik Patch, Shavlik Protect and manual installs.  From our testing, we too have seen explorer crashing even when attempting to install by hand.  This is an issue with the Z-zip installer and we haven't come up with a method to work around it.  I would highly recommend filing a defect with the vendor at this time.

               

              Thanks,

              Charles 

              • 4. Re: 7-Zip 16.00 x64 fails to install
                croth2 Apprentice

                I don't know where/how to go about that.  Not to mention I would think something like that coming from a company that does updates for a living, Shavlik, with I am sure thousands/tens of thousands/ millions/etc. of customers would pull more weight with the software vendor than me, singular joe blow admin.  You as Shavlik folks need to do that on behalf of us the customers if you haven't already.

                 

                For now I have deleted deployments for the update and will let it sit until an updated version for you or the vendor comes along.

                • 5. Re: 7-Zip 16.00 x64 fails to install
                  travisschuur SupportEmployee

                  We just released a catalog update that contains the new 7-zip 16.01. Looks like the issue was with 7-zip and they claim they have fixed the explorer.exe crashing issue in the new release.

                   

                  Thanks

                  Travis

                  • 6. Re: 7-Zip 16.00 x64 fails to install
                    Rookie

                    I apparently have a different issue w/ the 64bit deployment of 7-Zip 16.0 (and 16.01) in that none of my 64bit machines detect that it is required.  I have no problems w/ the 32bit version.

                    • 7. Re: 7-Zip 16.00 x64 fails to install
                      Rookie

                      I've submitted a support ticket for my issue

                      • 8. Re: 7-Zip 16.00 x64 fails to install
                        mreny Rookie

                        On Friday, I scheduled 7ZIP-006  7-Zip 16.01 for download from Shavlik Patch.  I come in this morning and it shows that it was downloaded, but the update is not being listed within "All Software Updates" within SCCM.  Any idea how I can get this update to list so I can push out the update.

                         

                        Mark

                        • 9. Re: 7-Zip 16.00 x64 fails to install
                          croth2 Apprentice

                          Did you publish or just click download?  You have to publish and choose to synchronize after publishing.  Did you run synchronization with WSUS post publishing?  After that close and open SCCM Console and should see it.  Then deploy the update or software update group containing the update to a collection which has the computer you're testing in it.  On client, Machine policy update, wait a couple minutes.  On client, Software deployment evaluation, wait 5-10 minutes and it appears in Software Center, if you chose to show it in Software Center when Deploying the software.

                           

                          As for my results, I published the 7-Zip 16.01 x64 and my machine which I manually had updated to 7-Zip 16.00 x64 recognized the update and I told it to install.  It installed successfully.

                          • 10. Re: 7-Zip 16.00 x64 fails to install
                            croth2 Apprentice

                            eselke do you have the 64-bit version installed on the 64-bit computers?  Just because the computer is 64-bit does not mean the 7-Zip software is guaranteed to be 64-bit.  You could have a 64-bit computer with the 32-bit version installed for a piece of software in general so I assume 7-Zip would be the same way. 

                            • 11. Re: 7-Zip 16.00 x64 fails to install
                              mreny Rookie

                              When I select them they are automatically set to publish.  I am able to see those for the other updates that I support like Flash and java, but this one is a no show.  I even ran a Synchronize Software Updates and it still is not listed.  I can see the file folder out in my WSUS\UpdateServicesPackages from last week when I initiated the download.  Still not listing even after logging out and off the Server....

                              • 12. Re: 7-Zip 16.00 x64 fails to install
                                Rookie

                                Yes, the 64bit version is deployed to our 64bit systems.  If the 32bit version was installed, then I'd expect it to get patched w/ the 32bit update.  My issue is the installed 64bit client isn't getting the patch at all.

                                 

                                I opened a ticket w/ Shavlik on Friday and they've forwarded the info I gathered for them to the content team.  I think it is just missing something in the detection method that the 32bit version of the patch info has.

                                • 13. Re: 7-Zip 16.00 x64 fails to install
                                  croth2 Apprentice

                                  I thought the same, but then I looked at installable rules, found that it should be fine.  Presuming you're running 15.14 since you said having problems with 16.00 and 16.01.

                                   

                                  Snippets for installable rules for 15.14 software:

                                   

                                  MSI for 15.14:

                                  <bar:RegKeyExists Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{23170F69-40C1-2701-1514-000001000000}" RegType32="true" />

                                  <bar:RegKeyExists Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{23170F69-40C1-2702-1514-000001000000}" />

                                   

                                  EXE for 15.14 (I presume for EXE cause none of my machines have it:

                                   

                                  <bar:RegSz Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\7-Zip" Value="DisplayName" RegType32="true" Comparison="Contains" Data="7-Zip 15." />

                                   

                                  Does the client computer your trying to update have any of those keys?

                                  • 14. Re: 7-Zip 16.00 x64 fails to install
                                    Rookie

                                    The 16.02 update released yesterday has fixed the issue and is coming down to my 64bit machines (32bit as well).

                                    1 2 Previous Next