8 Replies Latest reply on Mar 16, 2016 11:31 AM by cwinning

    Deployment Notification not worked

    makamajo Rookie

       

      Hi!


      After we updated Shavlik Protect Advanced 9.2.0 we get no Deployment Notification via email.
      It worked before the upgrade.
      We need these notifications to owners of the machines so they know which machine should be patched.
      The date and time is important.
      However, it works if it patches the machine directly, then the notification email.
      Is it a bug?

      If it is not, so we need help how to fix this.

      Regards / Maria Jonsson

       

       

       

        • 1. Re: Deployment Notification not worked
          cwinning CommunityTeam

          Hello,

           

          I'm not aware of any known issues with sending reports in Protect 9.2.  Please submit a case and include logs capturing your attempt to reproduce the issue.

           

          1. Please open the Protect GUI and then go to Tools > Options > Logging and change logging to “All” for both user interface and services.

          2. Close the Protect GUI.

          3. Stop the following services

               a.Shavlik Protect Console Service

                b. ST Remote Scheduler Service

          4. Delete all the logs from

               a.  Windows 7, 8, 2008, 2012 & Vista: C:\ProgramData\LANDesk\Shavlik Protect\Logs

          5.  Start the console service and open the Protect GUI.

          6. Attempt to reproduce the issue. Please document steps to reproduce.

          a. Collect the logs from the Logs folder mentioned earlier in step 4 (please zip if possible)

          7. Zip and attach the logs to the case.


          Let me know if you have any questions.


          Thank you,

          Charles

          • 2. Re: Deployment Notification not worked
            makamajo Rookie

            Hello again!
            Thank you for the answer.
            The service ST Remote Scheduler Service, is not on my server.
            Could it be that which is wrong?
            How do I install the service?


            Thank /Maria

            • 3. Re: Deployment Notification not worked
              Jonathan.JANVIER SupportEmployee

              Hello Maria

               

              We use the Microsoft Task Scheduler since 9.2 to scheduled the console jobs, so that's normal if you do not have the ST Remote Scheduler anymore.

               

              As Charles stated we are not aware of issues with reports in 9.2, please open a case with support so we can verify that everything is set up correctly.

               

              Regards,

              Jonathan

              1 of 1 people found this helpful
              • 4. Re: Deployment Notification not worked
                cwinning CommunityTeam

                Hello,

                 

                The Protect console logs indicate the files are copied to the target and it was scheduled to run.  We need the target side logs to determine if the job started and is the patches installed.

                 

                They are located in the C:\Windows\ProPatches\Logs folder.


                Thanks,

                Charles

                • 5. Re: Deployment Notification not worked
                  makamajo Rookie

                  Hi

                   

                  I hope it's correct log now?

                   

                  Regards / Maria

                   

                   

                  • 6. Re: Deployment Notification not worked
                    cwinning CommunityTeam

                    Hello,

                     

                    The combination of the console and target logs are helpful.  Could you please explain this?  "However, it works if it patches the machine directly, then the notification email."  What does directly mean?  What is the difference between the working and non-working configuration.  I just need to make sure we are on the same page.  screenshot would be great.


                    Thanks,

                    Charles

                    • 7. Re: Deployment Notification not worked
                      makamajo Rookie

                       

                      Hi

                      We want an email to be sent out after I scheduled security updates, with the date and time when it occurs.
                      for example:

                       

                      The patches listed below are scheduled for installation to the following machines

                       

                      Machine Name Scheduled Installation Time Bulletin/Patch

                       

                      WORKGROUP\marias 2016-03-11 04:00:00              MS16-026/Q3140735

                       

                      After installation, the machine will be:

                       

                      Automatically rebooted immediately after installation

                       

                      (So it looked like before the upgrade)

                       

                      Now posted no message when I scheduled, for example, tomorrow at 04:00 am
                      In contrast, posted the message if I run the patches directly.
                      then it looks like this:

                       

                      Machine Name Scheduled Installation Time Bulletin/Patch

                       

                      WORKGROUP\marias Immediately MS16-018/Q3134214

                       

                      Hope you understand what I mean.

                       

                      Regards/Maria

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      • 8. Re: Deployment Notification not worked
                        cwinning CommunityTeam

                        Hello,

                         

                        I spoke with a developer on this and it's possible this is a defect in Protect 9.2.  We would like a case on this:  https://support.shavlik.com/CaseLogging.aspx

                        Please include examples of the report showing the date and time and the one that doesn't.

                        Also, include instructions on the method that show the date and time and the one that doesn't.

                         

                        Please include a link to this thread.

                         

                        We can get this escalated as soon as we get the case.

                         

                        Thanks,

                        Charles