5 Replies Latest reply on Mar 1, 2016 1:31 PM by cwinning

    Shavlik Scan Issues

    Rookie

      Before I had issues with scanning particular machines that seemed to not even see the Shavlik console, now however I have noticed that now the machines that cannot be scanned with the consoles scheduled task seem to be completely fine when I schedule the scan individually through machine view. Why is this happening exactly? Is there something that I need to change agent side or is this just something that happens cause I'm pretty lost.

        • 1. Re: Shavlik Scan Issues
          cwinning CommunityTeam

          Hello,

           

          Can you verify that you have agents installed?  If yes, are you trying to initiate agentless scan from View > Machines? A screenshot(s) of what you are doing and seeing would be great.

           

          Thanks,

          Charles

          • 2. Re: Shavlik Scan Issues
            Rookie

            So I do not think I can screenshot this unfortunately as these are government systems, but I can say that it does indeed have the agent installed, but when I have it set up in a Machine Group it puts out Error 201 "Network Connection Error".  When I go into View> Machines and then find the machine alone in machine view I right click it and go under Patch Scans and pick the scan of my choosing it successfully scans it with no problems.  For some reason it does not want to scan in groups.  Again I do know that the agent is installed and configured for the correct port and for the the server which it has direct connection with through our domain.

            • 3. Re: Shavlik Scan Issues
              cwinning CommunityTeam

              Hello,

               

              Scans performed from a Machine Group are 100% agentless (bypassing the agent) so agentless scan perquisites apply.  http://help.shavlik.com/Protect/onlinehelp/92/ENU/EN/Scanning_prerequisites.htm

              In View > Machines, right-clicking on the machine and choosing Patch Scan > Your Patch Scan Template is also an agentless scan bypassing the agent installed on the target machine.

              It's very odd that View > Machines is working but a Machine Group isn't, it's usually the other way around due to potential credential issues.

              The Error 201 is fairly simple to troubleshoot in most cases.  It pretty much means you can't resolve/connect to the machine defined in the Machine Group.

              Since View > Machines scans via the NetBIOS name, you should make sure the Machine Group also contains the NetBIOS name and not FQDN or IP Address.

              For testing, you should create a new Machine Group.  Add the Machine Name (netbios). You should also set credentials in this Machine Group. 

              Does that scan?  If not, what is the error?

               

              To scan through the agent, you would need to either 1) allow the scheduled agent scan to run at it's normal time.  This is set in the Agent policy.  2) Run a scan from the Agent UI on the target machine or 3) Go to View > Machines, right-click on the machine, choose Agents > Run Task from Policy > Choose the task from the list.  Those are the only methods for an agent to run the patch scan.

               

              I hope that makes sense.

               

              Thanks,

              Charles

              1 of 1 people found this helpful
              • 4. Re: Shavlik Scan Issues
                Rookie

                Ok. I think I managed to make it work.  To set up these groups I had been adding the machines by seeking through the list received from the active directory.  Where this machine in particular is listed and I added it in the same manor, it failed to elaborate the domain name of the machine even though it was listed with the elaboration on the name it wasn't actually scanning for that.  Manually typing it and adding it to the group seemed to make it work out though.  Also as a side note as this is a government network we do not use NetBIOS and have it disabled through Group Policy.  I assume the only reason it was working through Machine View and not the Machine Group is because the incorrect name as the target. Now it seems fine though.  Thank you for all the help.

                • 5. Re: Shavlik Scan Issues
                  cwinning CommunityTeam

                  Glad to see you scanning, let us know if you need anything else.

                   

                  Thanks,

                  Charles