1 Reply Latest reply on Feb 5, 2016 9:50 AM by cwinning

    Can I force Shavlik to run using .NET Framework 4.6.1?

    Rookie

      The DoD mandated we uninstall unsupported versions of .NET Framework, on of which was 4.0. The next time I tried to run Shavlik Protect, I got "To run this application, you must install one of the following versions of the .NET Framework: v4.0.30319." I was going to bite the bullet and re-install that version, but it won't install while a newer version is installed, which there is. I'd rather not strip all .NETs off and start over, so a much more desirable solution would be to have Shavlik use the version .NET we have installed, which is still supported.

        • 1. Re: Can I force Shavlik to run using .NET Framework 4.6.1?
          cwinning CommunityTeam

          Hello,

           

          Protect 9.2 should work when .Net 4.6.1 is installed.  From what I know, .Net 4.6.1 will install components for earlier versions of .Net and Protect requires them to run.  Did you install .Net 4.6.1 then uninstall .net 4.x and earlier versions??  If so, you may corrupted .Net on the server and at the very least Protect won't run.  Try removing all versions of .Net then installing .Net 4.6.1, does that work?

           

          Thanks,

          Charles