4 Replies Latest reply on Jan 26, 2017 4:18 AM by michael.odriscoll

    Deploying IE 11 not working

    Rookie

      Hello all,

      I'm new to posting on the forum. I been around here for a while but always found solution to what I was looking for. But this time I can't figure what I'm doing wrong.

      I followed a document that shavlik did for installing IE 10 or IE 11. That didn't work. At the moment our workstations have IE 10 installed. Not all workstations need to be upgraded to IE 11 so don't really want to push to all workstation.

       

      Is there some kind of tutorial I could follow? I did find the Qnumber for IE 11 Q2841134 . I created the patch group, template for scanning .

       

      Any kind of help would be awesome.

       

      Thank you,

        • 1. Re: Deploying IE 11 not working
          Rookie

          Hey Louie,

           

          I just went through updating all our machines to IE11 from IE10, so hopefully my experience will help you.

           

          Here is how I set it up.

           

          Patch Group is setup with the MSIE-011 Q284113N Software Distro Patch. I named it PROD-IE11-SWD.

           

          Patch Scan Template is setup with only the PROD-IE11-SWD Patch Group selected. Scans for Missing, Installed, and Effectivly Installed under the general tab. I named it PROD-IE11-SWD also.

           

          That's pretty much it. I scanned the PC's in my machine group using the PROD-IE11-SWD Patch Scan Template and it found and updated the PC's without issue.

           

          In what way is nit not working for you?

          • 2. Re: Deploying IE 11 not working
            Rookie

            Hi Louie. I see this post is a little older, but I am doing this right now. I have found that there are 7 non-security patches that are prerequisites to installing IE 11. They need to be applied to the machines first, and then the upgrade will work. They are MSWU-639, MSWU-476, MSWU-653, MSWU-698, MSWU-716, MSWU-769 and MS11-A04. In my environment, I added these to my regular patch group and then created a separate patch group for the upgrade which I ran after the regular one completed.

            • 3. Re: Deploying IE 11 not working
              ctodd Rookie

              I was doing an IE11 upgrade the hard way and ran across a problem with KB2834140.  It seems that I had patched machines with this patch before, but the IE11 install log kept complaining that c:\windows\system32\d3d11.dll was at 6.1.7601.17514 instead of 6.2.9200.16570.  After much confusion, I found a thread telling me that KB2934140 came out with a -v2 of the same patch.  If I tried to install the -v2 of the patch over top of the existing one, it claims to have already installed the KB.  I was forced to manually remove the old version and then apply the new version, do a reboot, and then install IE11.  Quite a pain.

               

              I hear you ask, "A reboot should not be necessary so what gives?"  Well, even after installing the -v2 patch, the IE11 installer was still complaining about d3d11.dll's version.  It was no longer at 6.1, but it was now somewhere between the old version and the required version.  A reboot cleaned up whatever was going on and someone with a bigger clue might be able to do it without the reboot.

               

              I wish I had found this thread earlier.  The "deploy software with a patch scan" still doesn't quite click with me, so I had to write a batch script to install IE11, which totally felt wrong.  Shavlik, how I wish you would just be a little more clear. 

              • 4. Re: Deploying IE 11 not working
                michael.odriscoll CommunityTeam

                Discussion successfully moved from Site Help to Shavlik Protect.