4 Replies Latest reply on Apr 23, 2015 7:20 AM by cwinning

    New user cannot connect to Protect DB

    Rookie

      I am a new user in an existing installation of Shavlik Protect. Whenever I attempt to open Protect, it tells me the the following error: "Unable to connect to SQL Server '(local)\SQLEXPRESS'. Cannot open database "Protect" requested by the login. The login failed. Login failed for user1.

       

      Any help would be greatly appreciated. I have been going around and around on this for a few days and getting nowhere.

        • 1. Re: New user cannot connect to Protect DB
          cwinning CommunityTeam

          Hello,

           

          You are going to need to provide a valid login for the database Protect is connected to.  Run the Database Setup Tool found in the All Programs > Shavlik Protect.  Run the Tools and choose Use An Existing Database, it should populate the SQL server and database information for you.  You could hit the test button and try supplying valid credentials from there.

           

          This may also help if you need to add an account in SQL:  SQL Account Configuration - Privilege or Role Requirements for Protect Database

           

          Thanks,

          Charles

          1 of 1 people found this helpful
          • 2. Re: New user cannot connect to Protect DB
            Rookie

            Charles,

             

            Many thanks for your quick response. I have been the DB Setup tool a million times to no avail. Hitting the Test button tells me I dont have permissions even though I am a member of the Administrators group, etc. I will look through the link you pasted and try that and report back.

             

            Thanks again.

             

            Parker

            • 3. Re: New user cannot connect to Protect DB
              Rookie

              I tried doing the what you said above (and in the link) but it will not let me. It states that I dont have permissions to do it. There is another user who has been using it for a few years (on same computer) and he doesnt have any issues logging in to Shavlik Protect, but MS SQL Express Studio gives him the exact permissions errors that I receive. We receive error 2571 when trying to "attach" the Protect DB, etc.

               

              Short of reinstalling Protect, we are at the end of the rope. I dont think its a SQL issue since we both get the same error but he is allowed in and I am not.Neither of us see Protect in the list of DB's in SQL Studio so there is no way for us to attach it. If I use the DB Setup Tool in Shavlik I get a permissions error there too.

               

              Thanks.

               

              Parker

              • 4. Re: New user cannot connect to Protect DB
                cwinning CommunityTeam

                Hello,

                 

                My educated guess is the database was create when Protect was installed and since then something has been locked down in SQL or some other security setting has been implemented.  The error 2571 is a Microsoft SQL error, it hints at permission issue but nothing more than vague references.  As I don't see an previous cases with this error all my suggestion will be from research on the internet.

                 

                (check the SQL logs every step of the way for obvious SQL errors)

                 

                1.  Run the Database Setup Tool found in the All Programs > Shavlik Protect. Choose to create a new database, give it a name other than Protect.  This test will tell you how far down the rabbit hole this issue goes.  Does it work?  Are you able to open Protect with this new database?

                2. Try running the Database Setup Tool by right-clicking on and choosing to Run As Administrator.

                3. You could try giving yourself full permissions to the Protect .MDF and .LDF and the folder the database file are located in.

                4. Install all service packs and patches for SQL.

                5. Attempt to use the SA account (you may need to enable it)

                6. You could try detaching then reattaching the database. Caveat, you may not be able to reattach the database if you are having permission issues.

                 

                7. If you are still running SQL express 2005, you could try using a newer version of Express.  This is what I would do to accomplish this...

                 

                This will require upgrading to Protect 9.1 which requires a 64bit OS.

                 

                1. Make a full backup of your database using Management Studio Express.  (you may need to install this)

                2. Uninstall Protect.

                3. Uninstall SQL Express then restart the server.

                4. Download and install the latest version of Protect 9.1:  http://www.shavlik.com/support/protect/downloads/

                5. The install should ask whether you want to install SQL Express, choose yes.

                6. Allow the installation to complete, change the name of the database to ProtectTest when you get to that stage.

                7. Verify Protect opens after the install complete then close it.

                8. Open Management Studio Express, you may need to install this, and restore your backup of the Protect database.

                9. Once restore, run the Database Setup Tool and choose existing database.  Choose the Protect database from the drop down.

                10. Assuming everything completed without issue, open Protect.  (you will need to re-add credentials and verify other configuration settings)

                 

                All of this comes with some risk, but I'm not aware of any alternatives.

                 

                Thanks,

                Charles