9 Replies Latest reply on Oct 29, 2014 10:31 AM by bc_rs

    Java 7-71

    pjohnson Rookie

      Hello everyone,

       

      I have tried to deploy the latest Shavlik patch for Java (Java 7-71 CPU) and it has failed repeatedly - returned: 3010.

       

      Windows 7, 32 bit OS. Any ideas?

       

      Thanks,

       

      Paul

        • 1. Re: Java 7-71
          cwinning CommunityTeam

          Hello,

           

          A 3010 would indicate a successful installation.  Are you allowing a reboot, it is required for this patch.

           

          Thanks,

          Charles

          • 2. Re: Java 7-71
            pjohnson Rookie

            Yes the machine(s) are scheduled for a re-boot.

            • 3. Re: Java 7-71
              cwinning CommunityTeam

              Hello,

               

              We're going to need a case for this type of issue.  Attaching a DPDtrace to the case would help speed up the process.

               

              Support Portal

              DPDTrace Instructions  (use patch-type 13)

               

              Thanks,

              Charles

              • 4. Re: Java 7-71
                pjohnson Rookie

                Okay I believe I may have narrowed it down but it will require further testing. On the previous three unsuccessful attempts, under the 'General' tab I selected 'Remove temp files'. The last attempt I did not select that box and it worked successfully. I will report back once I verify on a few more machines.

                 

                Thanks,

                 

                Paul

                • 5. Re: Java 7-71
                  cwinning CommunityTeam

                  Hello,

                   

                  I would be very interested in the outcome.

                   

                  Thank you,

                  Charles

                  • 6. Re: Java 7-71
                    cwinning CommunityTeam

                    Hello,

                     

                    I believe you are on to something here.  There are dependent actions that are performed at system startup to completely install Java at reboot.  This is required if there are Java files locked during the initial install attempt before the system restart.  The option to Remove Temp Files after deployment would break this process.  So in essence, the Remove Temp Files shouldn't be used when installing Java patches.

                     

                    Thanks,

                    Charles

                    • 7. Re: Java 7-71
                      pjohnson Rookie

                      Okay so after further testing that is the case. Having the 'remove temp files' selected will cause the patch to fail. I wonder if we can run some other process that will remove the downloaded patch files from the machines periodically? It wouldn't take long for the patches to take up considerable space if we can't remove them during deployment.

                       

                      Thanks,

                       

                      Paul

                      • 8. Re: Java 7-71
                        cwinning CommunityTeam

                        Paul,

                         

                        I agree with you concern, here are a couple of ideas.

                         

                        1)  Scan/Deploy Java separate from the rest of your patches.

                        2)  Use a Custom Action to delete the content of the C:\Windows\ProPatches periodically.  This is something that doesn't require a reboot and could be run anytime you like:  How To Remove The Propatches Folder Using Custom Actions in Protect 9.1

                         

                        Let me know your thoughts.

                         

                        Thanks,

                        Charles

                        • 9. Re: Java 7-71
                          Rookie


                          In my case I had to allow Shavlik to reboot after patching for Java 7 Update 71 to show as successfully patched.  If I reboot the server manually after patching it still shows up as unpatched.  (My 'remove temp files' was unchecked)