4 Replies Latest reply on Nov 12, 2014 4:04 AM by human

    How to scan by FQDN or IP (not Machine Name)

    Rookie

      Having problems talking to my client.  Shavlik will be able to tell me what patches are installed and what's missing. But if I attempt to run a Patch Scan it gives me Error 201.

       

      Now I've been looking at this for the past hour and I have narrowed down the fact that if I RDP (through the Shavlik console) to the client I can do this by IP address.  But it will error out if I attempt to try this using simple machine name.

       

      Unless I can make the machine name show up as the FQDN (machine.sub.domain) this doesn't work with RDP.

       

      So... when I run a patch scan it appears my only option is by the simple machine name and it doesn't fully work.

       

      Is there a way to change this within Shavlik?  I bet if I can get it to scan using the FQDN or IP...  I bet it'll work just fine.

        • 1. Re: How to scan by FQDN or IP (not Machine Name)
          Rookie

          Just going to clarify something here.

           

          When I do the initial search for a computer to be added to my group I do it by IP address/Range.  In doing this it picks up the client device, successfully scans it and adds it to my group.

           

          But the problem is when you attempt to run a scan (Patch:Security Patch Scan) to those devices already in the group.  At this point it no longer uses the IP selection, but the simple computer name.  And during this scan it will suddenly give the Error 201.

          • 2. Re: How to scan by FQDN or IP (not Machine Name)
            Rookie

            Found a similar thread on this topic called "DNS instead of NETBIOS" http://community.shavlik.com/thread/445119

             

            Unfortuntaly there was never an answer given.  So I've followed their example and submitted a ticket.  Hopefully I'll get an answer and post it here.

            • 3. Re: How to scan by FQDN or IP (not Machine Name)
              Bhays SupportEmployee

              Hi,

               

              I would like to explain a few things to clarify how Shavlik scans and resolves machine names/IP addresses. When originally added to the machine group, whether it is added by IP address, short machine name or FQDN, Shavlik uses that input value to scan the machine. In your case you added the machine by the IP address to the machine group, it used the IP address to contact the machine and the scan worked. However scanning again produces a 201 Error, system not found. 

               

              The second scan was performed by selecting the machine from machine view, right clicking and scanning with the Security San. When selecting and scanning a machine from machine view the resolution is performed using the short name of the machine. In your case the short name of the machine could not be resolved, so the scan failed.

               

              The solution is to be able to resolve the short name of the machines via DNS. As a workaround you can scan all machines from their machine group where they were added by the IP address, short name or FQDN. This will force Shavlik to resolve using the original input instead of the short name of the machine.

               

              Thanks,

              Brittany

              • 4. Re: How to scan by FQDN or IP (not Machine Name)
                human Rookie

                I'm running into this issue also. I'm having trouble resolving machines in a different domain to the console. Within the machine group the machines have their FQDN as their machine name. With this in place the machines scan fine, and even deploy patches fine. However, when I try to do a test deployment or I try to refresh the machines from within the scheduled tasks view I get a timeout. This is caused by these two operations using the short name. When I add a host file entry on the console machine all operations complete successfully so the short name is key here. Adding host file entries isn't an acceptable option as I've got thousands of servers to patch.

                 

                I don't understand why there isn't a consistent use of one identifier over different operations within the tool? Ideall I'd like to see IP used for everything and the FQDNs displayed for easy of administration.

                 

                I've got a support ticket open at the moment so hopefully I'll get a resolution which I'll post here.