2 Replies Latest reply on Jun 17, 2014 12:18 PM by BeckyP

    Java 7_45

    Rookie

      Hi all,

       

      I am experencing issues using Shavlik to deploy Java 7u45. 18 of 54 systems did not get updated. On a test machine that had the issue this is what I did.

       

      • Scanned the system with the default patch scan temmplate, and it indicated that Java 7u45 was available. (installed version was 7u40)
      • Using the default deployment template from Shavlik I apply the update
      • Subsequent scan shows Java 7u45 still missing (Confirmed locally on the machine that Java 7u40 is still installed)
      • Locally on the machine I disabled Java update service and rebooted
      • Rescanned and reapply the update. Still no success
      • Reboot the system, rescan and apply update. Still no success
      • Locally I rename the relevant Shavlik script from .his to .bat and try to run the script locally. Still does not install
      • On the local machine if I double click the Java 7u45 file (which Shavlik places in the "ProPatches\Patches" folder) it installs

       

      I have looked over the best practices guide and tried what I could, but this is happenening randomly on every Java update thru Shavlik. Last month it was 10 systems that had the issue and I had to manually go to each system and install the update. All systems are running an identical corporate image and there is nothing to indicate why the installs continue to fail randomly. We have no GPO's or security policies that I can see would cause the issue. Our usual process is to run the updates overnight using a custom template which includes a post install reboot. All other patches install fine but Java continues to be an issue.

       

      We are running the latest version of Protect Advanced. I must be missing something. Does anyone else have similar issues?

       

      Thanks everyone