4 Replies Latest reply on Jun 27, 2013 9:10 AM by jherbig

    Protect not scanning all VM's


      I have 14 VM's that are in a machine group. They are attached by hosted vm method. When patch scanning, Protect states x of 14 being scanned but in the end lists 6 of 6 scanned. When the job is completed the results also state "warning: scan still running - incomplete results" even after the system delivered the emailed reports. These VM's are typically off, but i get the same results whether they are on. I've also attempted to add them through AD and left them on for a scan. Not error messages appeared.

        • 1. Re: Protect not scanning all VM's



          First thing - which version of Protect are you currently running? You can verify under Help > About.


          With the error you're receving it's most likely that not all the scan results have been imported to your database which makes it appear that the scan hasn't run on all the systems in your group. Once I know the version you're on I will provide some troubleshooting steps.

          • 2. Re: Protect not scanning all VM's

            9.0.0 build 1106

            • 3. Re: Protect not scanning all VM's

              Here are some things to check and/or try for this issue:


              1) Check for previously imported results that are stuck in the arrivals directory. These temporary files can be deleted. They can be found here:


              -On Vista/2008/7: C:\ProgramData\LANDesk\Shavlik Protect\Console\Arrivals

              -On XP/2003: C:\Documents and Settings\All Users\Application Data\LANDesk\Shavlik Protect\Console\Arrivals


              2) If your Protect console is installed on a 2003 or XP system, make sure the HTTP SSL service is started and automatic.


              3) If you're using an Express version of SQL, make sure that the database isn't full - 10GB is the limit for SQL Express 2008R2 & newer. 4GB is the limit for older versions of SQL Express. You can use the database maintenance function in Protect to help clear up space - it can be found under Tools > Database Maintenance within Protect.


              4) In Protect go to Help > Index and look up the “SQL Server Post Installation Notes” document. Follow the directions within.


              5) Close Protect, Restart the Shavlik Protect Console service. Reopen Protect.



              After these steps, test running a few scans and see if results show up fine now.


              If results are still failing try this:

              -Alternate credentials for the console service: Close Protect, then go to Start > All Programs > Shavlik Protect > Database setup tool. On the "SQL Database Configuration" screen where it shows "Choose how services will connect to the database", check mark the option to Use alternate credentials for console services. Then set the Authentication method (the most common would be Specific Windows User), then set domain admin or service credentials. Finish through the setup tool, and test scanning again.


              If you still have an issue, please go through the following steps to obtain trace logs and send them to support:


              -In Protect go to Tools > Options > Logging and make sure both User Interface and Services are set to “All”. Save.

              -Close Protect.

              -Stop the Shavlik Protect Console services.

              -Delete all the logs from:

              -Vista, 2008, & Win7: C:\ProgramData\LANDesk\Shavlik Protect\Logs

              -Windows XP & 2003: C:\Documents and Settings\All Users\Application Data\LANDesk\Shavlik Protect\Logs

              -Start the Shavlik Protect Console service and open Protect.

              -Reproduce the error/issue.

              -Afterwards please zip and send all the logs.


              I hope this helps!

              • 4. Re: Protect not scanning all VM's

                The issue remains. Attached are the logfiles. I did notice that the vm’s that are not showing up are in the files located in C:\ProgramData\LANDesk\Shavlik Protect\Console\Arrivals\Patch\Xml\BadFiles