2 Replies Latest reply on Mar 1, 2013 3:33 PM by danh2010

    On trial version - Patches still show scheduled


      I am still evaluating the Protect, so I am using the trial license.


      I have added my group, rean a patch scan and successfully deploed the patches.

      All of them still show for Current Patch Status = Scheduled


      I have rebooted and rescanned.  No difference.


      How long does it take to register as patched or I am doing something incorrectly?



        • 1. Re: On trial version - Patches still show scheduled



          This same issue is actually covered in a recent community post: http://communities.vmware.com/thread/437267?tstart=0


          Here is what to check (with some clarification included):


          If you deploy and see it sitting at scheduled - go to the target system, C:WindowsPropatchesInstall. Of the newest files in this folder do you have a .bat or .HIS file here?


          .bat will still exist if the deployment job has not run - Indicates a scheduler problem.

          .HIS will exist if the deployment job has run and completed - Indicates the 'scheduled' status is due to a deployment tracker problem.


          If the issue is a deployment tracker problem:


          The tracker uses port TCP 3121 to communicate with the Protect console - the most important thing is to verify this port is open from the target system back to the console system.


          Also check that your tracker address is set to the correct address in case the console system has multiple NICs or addresses that could be used. You can verify the address the tracker uses in Protect under Tools > Options > Deployment.


          If the issue is due to a scheduler problem, go through the following:


          -Verify your settings in Tools > Options > Scheduler. Ensure that the scheduler port configured is open for communication from you Protect system to all target systems.

          -Verify that you have proper credentials set on the machine(s), machine group(s), and for default credentials.


          Try reinstalling the scheduler service to see if it helps resolve the issue:


          Perform these steps on a target machine:
          Manually remove the Shavlik/VMware Scheduler:
          CD to C:windowsPropatchesscheduler
          Run stschedex.exe /remove
          Delete the folder: C:WindowsPropatches.
          Delete the reg key (for verfication; the command should delete this): HKEY_LOCAL_MACHINESOFTWAREShavlikScheduler
          Perform these steps in Protect:
          For VMware vCenter Protect 8.x:
          -Go to Manage > Credentials. Add credentials you wish to use as default or edit existing credentials to ensure that the password is up-to-date. Make sure to set the proper credentials as the "default credentials".
          -Go to Tools > Options > Scheduling and make sure the VMware Scheduler is chosen.
          -Run a new scan to the target machine prior steps were performed on using Security Patch Scan.
          -Once the scan completes deploy to this machine using the Standard deployment template. Deploying will cause the scheduler service to be reinstalled.
          -You can also reinstall the service by going to Manage > Scheduled Tasks > Right click on the target machine > choose Scheduler Service > Install.



          I hope this helps. If it does not, it may be best to contact support directly for further assistance with troubleshooting.

          • 2. Re: On trial version - Patches still show scheduled

            Thanks.  My port was being blocked.




            >>> adamg23 <communities-emailer@vmware.com> 3/1/2013 4:07 PM >>>

            adamg23 http://communities.vmware.com/people/adamg23 replied to the discussion


            "On trial version - Patches still show scheduled"


            To view the discussion, visit: http://communities.vmware.com/message/2204090#2204090