6 Replies Latest reply on Mar 4, 2013 2:39 AM by Faltherren

    Updates not installing on servers

    Rookie

      I'm working as a technician at one of our customers who uses vCenter Protect and i have little to no experiance redarding Protect. A couple of months ago the updates apparently stopped installing on the servers.

       

      Scans are scheduled and running every night. When in Protect looking at Results is says the scan was completed and the template was run. There is a number of patches for each server under the Total Patches Deployed-column. Still in the Results pane, selecting a server and choosing Deployment Summary it says that the patch was either Download and Scheduling successful or only Scheduling successful. If I click Query remote log information i gett the following errors:

       

      ItemDateResults
      Error2013-02-20Unable to remote schedule log at 02/20/2013 11:30. Please try refreshing again later.
      ErrorOverlappend I/O operation is in progress
      Scheduler Event Log MessagesNo schedule log information

       

      However, patches are not in reality installed on any server. I log on to a server and navigate to C:WindowsProPatches. The newest patch in the Patches-folder dates 2012-09-14. In the Install-folder there are .BAT-files created after each scan with .CFG- and .MAP-files. Last time a .HIS-file was created was 2012-11-01.

       

       

      Patches can be installed if I run a manual scan and install immediately.

       

       

      Looking at the template here are the following Deployment Actions:

       

      BeforeDuringAfter
      Shut down SQL ServerBackup files for uninstall
      Warn connected machinesQuiet Mode
      Send Tracker status

       

      Pre-deployment Reboot-tab:

      Never reboot before deployment

       

      Post-deploy Reboot-tab:

      Always reboot after deployment

      Imediately after installation

      Force action after (minutes) 10

      Extend time-out up to the scheduled action time (increment in minutes) 5

       

      Distribution Servers-tab:

      Use Server by IP Range

      After machine reboots and every 4, 8, 12, 24, and 48 hours afterwards

       

      Used by-tab:

      SQL Agent Policy

       

       

      I have tried to re-install the agent on the server. In Protect I have ran ToolsDatabase maintenance, HelpRefresh Files and also Check for Program Updates.

       

      Does anyone have any idea what's wrong or how I can get the updates installing?

        • 1. Re: Updates not installing on servers
          SupportEmployee

          Hello and welcome to the community,

           

          The first thing I'm noticing here is that you are specifying to use a distribution server in the deployment template. You always need to make sure that all necessary patch files for deployment are downloaded and synchronized to the distribution server - otherwise it can cause issues like this.

           

          Other than this - based on the last tracker messages you were receiving it could be an issue with the remote scheduler service we use on the target system.

           

          For the scheduler:

           

          -Check in the Protect console > Tools > Options > Scheduling to verify what scheduler settings you are using.

          -Ensure that the scheduler port is open for communication from the console system to the target systems (default port is TCP 5120).

          -You can try reinstalling the scheduler service. The easiest way to attempt this is to go into Manage > Scheduled tasks within Protect, then locate the target system in the left column. Right click and choose "Refresh selected". Once this is done, then right click on the machine again and choose Scheduler Service > Uninstall. Once this appears to be done then right click on the machine and choose Scheduler Service > Install. Try deploying again to see if this helps.

          1 of 1 people found this helpful
          • 2. Re: Updates not installing on servers
            Rookie

            Updates are downloaded on the distribution server.

             

            I think there is a problem with the Remote Scheduler. I tried your solution; refreshing the machines, uninstalling and reinstalling the Scheduler service. Earlier, all machines in the task list except the Protect-machine was greyed out. Now they have a coloured icon and if i select anyone of them they have pending jobs now. I'll let it be and see if the patches are deployed.

             

            Thank you so much for your help!

            • 3. Re: Updates not installing on servers
              Rookie

              Unfortunately it didn't work. Protect is set to use VMware scheduler on port 5120. The distribution server is in fact the Protect-server. How can I make sure the patch files are synchronized?

               

              Here are some events from three diffirent servers.

              heimdall.PNG

              alapp02.PNG

              alsql02.PNG

               

              I have earlier tried to re-install the agent, but that did not solve the problem. It seems that the patches are not copied to the machines. Nearly all of my customers machines are virtual.

               

              I logged on to a server and opened up the Protect Agent and I get the following error message. I double checked the location and there was indeed no Protect.manifest.xml. I also checked the agent on a couple of other machines and the same error occured.

              protectagent.png

               

               

              I also found on some servers thet had the .xml-file but the manifest was too old. I have in Protect Used Refresh Files but it seems like I get errors downloading the xml-files. I also tried to update the binaries on the server that had the old manifest without luck.

              refreshfiles.PNG

              • 4. Re: Updates not installing on servers
                SupportEmployee

                It looks like your first issue presented is with agentless deployment, but now there is an agent involved here. Is the issue with one or the other, or both? It seems like this issue is becoming a little more complicated, and it will probably be best to open a case with us (support) directly.

                 

                Contact information for support can be found here:

                http://kb.vmware.com/kb/2040883

                 

                It would be best if you can use the steps provided in the following KB's to obtain log files while reproducing the issue(s):

                 

                Protect console logs:

                http://kb.vmware.com/kb/2031065

                 

                Agent logs:

                http://kb.vmware.com/kb/2042112

                 

                Thanks!

                1 of 1 people found this helpful
                • 5. Re: Updates not installing on servers
                  Rookie

                  Thanks Adam! I will look into this.

                  • 6. Re: Updates not installing on servers
                    Rookie

                    Actually, I got some servers to update after finally being able to refresh the files on the Shavlik-server and then by manually updating agent binaries and patch data. I also had some luck with manually reinstalling the agents on some servers using this guide:  http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2031364 . Right now I am trying to figure out why not all servers got updated.