8 Replies Latest reply on Jan 22, 2013 11:22 AM by Extra77

    Snapshots

    Rookie

      Testing vCenter Protect standard at the moment and having difficulties with the snapshot facility prior to deployment, My policy is set to take a snapshot prior to deployment and hold it for 4 days but the snapshot never occurs. Setup is as follows

       

      Machine is added to my test group as a Hosted VM

      Admin Credentials set - These Credentials can manually take a snapshot of a server and set as default in the Credentials Manager

      Policy has a custom scan and deployment template (just to enable all windows update items to be scanned and deployed and Snapshot taken)

       

      Tried using the default VM standard template, still no Snapshot occurs.

       

      I can scan machines and deploy updates fine.  Looking at the version's I should still be able to take a snapshot with the standard version

       

      http://www.vmware.com/products/datacenter-virtualization/vcenter-protect/compare.html

       

      Any help appreciated ! cheers

        • 1. Re: Snapshots
          Apprentice

          My first inclination is that this is a credentials issue.  In your machine group do you have a browse credential assigned to this machine?  Also, are these scheduled scans/deployments or immediate?  I'm assuming the VM is powered-on since the scan and deployments work, just none of the actions that occur at the host-level.

           

          Thank you,
          Kevin McTague

          • 2. Re: Snapshots
            Rookie

            The credentials for browse and admin are set

            to the same account, it is a account in the admins group of VMware and can manually do a snapshot.

             

            Also this is for scheduled deployments, A snapshot still does not appear in the VMware  snapshot manager if I force any updates manually using the same deployment template even though the template is set to do so.

             

            This is just in a trail phase at the moment on a test server until I can get the snapshot function working and is online.

             

             

            Thanks

            • 3. Re: Snapshots
              Apprentice

              When you schedule a deployment, go to the scheduled task manager and locate the machine you are deploying to.  It should list the deployment job once you refresh the machine (right-click, refresh selected).  There is a field named "User to run as", you must log into the console with this account and set the browse credential.  If this does not resolve your issue, please contact tech support and we'll open a case for you.

              • 4. Re: Snapshots
                Rookie

                Hi there,

                 

                I'm having the same issue, it just doesn't try and create a snapshot even though the deployment template tells it to.  My scheduled task is set to run as 'LOCAL_SYSTEM', so does that need to be something else?  The server I am testing this on has been added as a hosted VM, so no option to add browse credentials.

                 

                Thanks,

                 

                Ben

                • 5. Re: Snapshots
                  SupportEmployee

                  It would probably be helpful to review the following Help articles within Protect:

                   

                  Help > Contents > Quick Start Information > Quick Start Info for Virtual  Machines > Notes About Virtual Machines

                   

                  Help > Contents > Installation and Setup > Using Machine Groups > Adding Virtual Machines to a Machine  Group > Adding Virtual Machines Hosted by a Server

                   

                  From the first article I mentioned this snippet may be helpful:

                   

                  When deploying patches to an offline virtual machine that is hosted on a  server, the following VMware server permissions are required in order to manage  snapshots and to change the power state of the machine during the deployment  process:

                  -VirtualMachine.State.CreateSnapshot

                  -VirtualMachine.State.RemoveSnapshot

                  -VirtualMachine.Interact.PowerOn

                  -VirtualMachine.Interact.PowerOff

                  -VirtualMachine.Interact.DeviceConnection (to disable/enable the network card)

                   

                  Also (in reply to Ben) you do need to set browse credentials. You can do this once you click to "add machine to group" for one of the hosted VM's. It will then appear in the lower section of the machine group, and you can right click and choose to set credentials.

                  • 6. Re: Snapshots
                    Rookie

                    Thanks for the reply.

                     

                    I've updated the server permissions as the 'interact' ones were missing.

                     

                    With regards to credentials, when I add this server as a 'hosted VM' and right click, my set browse credentials are greyed out.  I can set admin credentials ok, but never get the option for browse.  Am I missing something?!

                     

                    Thanks,

                     

                    Ben

                    • 7. Re: Snapshots
                      SupportEmployee

                      Well there's two main places to set credentials for hosted virtual machines:

                       

                      1) You add server credentials - this is done right when you add the ESXi or vCenter server to the group.

                       

                      2) Specific machine credentials - once you see the list of VM's on your server you have to add them to your group, and then you can set credentials for each individual machine.

                       

                      You can also set machine group credentials - this would apply for any VM's that you actually add into your group and don't set specific machine credentials.

                       

                      I hope that explanation makes sense and helps.

                      • 8. Re: Snapshots
                        Rookie

                        My solution for this was to use a agentless install / schedule. Even though my template had the "Take pre deployment snapshots" ticked and my setup had a specific schedule, the schedule would run, deploy patches but not take a snapshot of any hosted servers. I can still set a schedule with a agentless install but this has to be done from the Home screen (top left icon) select the group of servers you wish to deploy any required patches too and set the date and time / recurrence.

                         

                        I was told at the time of logging and investigating this with VM they will need to write a fix for this and release a patch update because the agent ignores any snapshot attempt thinking it is a physical server. I'm yet to receive any update for this though.

                         

                        Don't forget to remove the agent off your server prior to a deployment to it (you can always re-push this out in 2 minutes) secondly if you do a manual deployment when logged in it uses the credentials of the logged in user, Not the credentials set as the browse or admin credentials set in the protect console.

                         

                        You can allways test your account by logging into the Vcenter Protect server with the account your trying to use in the schedule and do a manual deployment and see if it works.

                         

                        Hopefully this sheds some light on your situation. Any questions fire away

                         

                        Cheers

                        1 of 1 people found this helpful