Error: "Unsupported Upgrade Version" When Connecting to a New Database

Version 2

    Purpose

     

    To address the error "Unsupported upgrade version. The application database must be at least version 9.0.1" when connecting to a new database.

     

    Symptoms

     

    You create a new database for your Ivanti Patch for Windows Servers (PWS) or Shavlik Protect console, then select "Use an existing database (link or upgrade)" in the Database Setup Tool.

     

     

    When you point to that database on the next step, you get the error "Unsupported upgrade version. The application database must be at least version 9.0.1."

     

    Cause

     

    The "Use an existing database" option is for linking or upgrading a database that has already been set up and configured by Protect or PWS, so that option will look for the database to have a compatible or upgradeable schema.  Since the new database has nothing in it yet, it is not compatible for linking or upgrading.

     

    Resolution

     

    To use an existing database that has not yet been set up by PWS/Protect, follow these steps:

       1. Click the option to "Create a new database" and click Next:

       2. On the next screen, point to the database you want to use and click Next.  You'll see a message pop up indicating that the database already exists, and asking whether you want to overwrite it:

       3. Click "Overwrite" to proceed with the installation

       4. You should then see the database installation complete successfully:

     

    Affected Product(s)

     

    Shavlik Protect 9.x

    Ivanti Patch for Windows Servers 9.3.x