All Patches Executed, but Deployment Tracker Stays Stuck at Executing

Version 2

    Purpose

     

    The purpose of this document is to cover why your deployment may stay stuck at "Deployment operation executing" even though all the patches have executed successfully

     

    Symptoms

     

    When you push a deployment, all the patches show a state of Executed in the Patch progress pane, but the deployment Status never updates past Deployment operation executing in the Machine progress pane.

     

     

    Cause

     

    This is a known issue in Patch for Windows 9.3 that occurs when you specify "Remove temp files" in your deployment template, and also don't reboot following your deployment, as illustrated below:

     

    NOTE: This also occurs if you select "Reboot when needed" and a reboot is not required by any deployed patches

     

    Resolution

     

    To avoid this issue, you must either:

    • Always schedule a reboot after patching (recommended)

         OR

    • Uncheck the "Remove temp files" option on your Deployment Template

     

    Additional Information

     

    If you need to avoid rebooting, but also need to manage disk space on your target machines, you can use a Custom Action to clean up the patches stored on your target machine until the issue is resolved in a future release:

    How To: Delete Patches from Target Machines Using a Custom Action

     

    Affected Product(s)

     

    Ivanti Patch for Windows Servers 9.3.x