Agent Scan Fails Due to 'Invalid ZIP Archive' Error After Patch File Download

Version 4

    Purpose

     

    The purpose of this document is to show how to resolve the issue when agents report an Invalid ZIP archive error during a patch scan.

     

    Symptoms

     

    When attempting to run an agent patch task from the agent GUI, you'll see a similar error to the one below:

     

     

    When the agent attempts to download the WindowsPatchData.zip, it fails due to the data being corrupted. In the STAgentUpdater.log, this is the error you may see:

     

    2017-07-21T17:00:01.5232054Z 1924 I AgentUpdatePatch.cpp:41 Patch file download started

    2017-07-21T17:00:03.5997420Z 1924 W AgentManagedFile.cpp:169 C:\ProgramData\LANDESK\Shavlik Protect\Agent\Patch\WindowsPatchData.zip may be corrupt.

    2017-07-21T17:00:03.6007449Z 1924 V AgentManagedFile.cpp:173 C:\ProgramData\LANDESK\Shavlik Protect\Agent\Patch\WindowsPatchData.zip not found. Assuming not current.

    2017-07-21T17:00:05.3123087Z 1924 E AgentUpdatePatch.cpp:64 Patch file download failed - 'class STCore::CInvalidOperationException at ZipArchive.cpp:150: Invalid ZIP archive'

    When trying to open the WindowsPatchData.zip from C:\Programdata\Landesk\Shavlik Protect\Agent\Patch, you may see this error:

     

     

    Cause

     

    Network resources such as firewalls, proxies, or Anti-Virus is causing the download of the WindowsPatchData.zip to be corrupted during/after the download is completed.

     

    Resolution

     

    1. Add the URL exceptions for our content sites - content.ivanti.com and xml.shavlik.com
      1. Full list of exceptions and IP's (if needed) for our content sites can be found in this document: Firewall and Proxy Exceptions URL List - Shavlik Protect/Ivanti Patch for Windows Servers (08/10/2017)
    2. Add the recommended AV exceptions to your AV policies.
      1. AntiVirus Exclusions For Patch Deployments
    3. Download a fresh copy of the WindowsPatchData.zip folder from this link.
      1. To confirm your download is not corrupted, you'll be expecting a file size of approximately 13.3 MB. Anything less and the file will not work.
      2. Once downloaded successfully, you can place the new file into C:\Programdata\Landesk\Shavlik Protect\Agent\Patch on the agent machine and then run your scan again.

     

    Affected Product(s)

     

    Ivanti Patch for Windows Servers 9.3.x