Protect Cloud Agent Registration Failed With No Obvious Error

Version 2

    Symptoms

     

    When you attempt to install a Protect Cloud Agent with a registration key you receive a Registration Failed error message. You've confirmed that all the requirements listed for installing the cloud agent are correct, and when you click Details you receive a log similar to the following:

     

    Cloud Agent Registration Failure.png

     

    Cause

     

    This error is caused when the Agent Key has expired through number of uses or passing the expiration date, as visible in the Protect Cloud site, under Agent Keys.

     

    Expired Keys.png

     

    Resolution

     

    You will need to create a new Protect Cloud Agent Key to use by:

     

    1. Going to the Shavlik Protect Cloud Portal
    2. Login with your Protect Cloud Account
    3. Click the tab for Agent Keys
    4. Click the New button
    5. Specify details for the key:
      • Console name: The Console the Cloud Agent will be reported to
      • Policy: The Agent policy the Cloud Agent will use
      • Max. number of installations: Maximum number of times the key can be used for registrations
      • Expires in (hours): How long the key will be active for
    6. If desired, specify email addresses to send keys to and whether or not to receive a copy
    7. Click Create Key

     

    Additional Information

     

    You will not need to download the Protect Cloud Agent installer again, just use the new Agent Key when performing the install and activation.

     

    Affected Products


    Shavlik Protect 9.x