McAfee Solidifier prevents the Shavlik Scheduler from functioning -  Failed To Schedule Patch Deployment - Cannot Start Service STSchedEx On Computer

Version 3

    Purpose

     

    The purpose of this article is to help troubleshoot the error that is encountered when trying to deploy patches to the machine but the ST Remote Scheduler Service could not be started. 

     

    Symptoms

     

    • You will see the following in the Deployment Tracker:  "Failed to schedule patch deployment - Cannot start service STSchedEx on computer 'Target IP Address', Failed"

    Errorpic.png

    • You also have McAfee Solidifier installed on the target machines.

     

    Cause

     

    1. The ST Remote Scheduler Service could be corrupted and you need to reinstall the service. For more information, please consult the following article before proceeding below: Custom Action - Remove the Remote Scheduler for Protect Version 9

    2. If you have McAfee Solidifier installed on the target machines, the application will prevent STSCHED.exe and STDEPLOY.exe from running. If this is the case, then you will need to proceed with the following instructions below.

     

    Resolution

     

    1. Login to the target machine with administrative account credentials.

    2. Click on Start > All Programs > McAfee > Solidifier > McAfee Solidifier Command Line.

    3. A command prompt opens up with the current directory being "C:\Program Files\Solidcore\S3".

    4. Type the following command:

    sadmin begin update
    

    5. Once you run the above command, the system enters an update mode, for performing software updates and installations.

    6. Now, install all applicable Microsoft Security Updates and restart the system once done. At this point run a Shavlik Protect scan and patch the machines as normal.

     

    Affected Product(s)

     

    Shavlik Protect 9.x