Missing Agent Policy When Creating an Agent Key via the Protect Cloud

Version 3

    Purpose

     

    The purpose of this document is to go over why a newly created agent policy that has the "Sync with Protect Cloud" feature checked may not show up in the Shavlik Protect Cloud Agent Key creation box and how to correct this.

     

    Symptoms

     

    When you log in to protectcloud.shavlik.com and select the Agent Key tab and create a New Agent Key, under the Policy drop-down box, you cannot find an agent policy that was created with the "Sync with Protect Cloud" feature checked.

     

    PolicyAgentKey1.JPG

    On the Shavlik Protect Cloud webpage (protectcloud.shavlik.com) after selecting "New" on the Agent Key tab:

    PolicyAgentKey2.JPG

     

    Cause

     

    The console has not performed a sync with the Shavlik Protect Cloud website.

     

    Resolution

     

    1)  Navigate to Tools > Operations > Protect Cloud Sync. Click on Force full update now. This forces the updated agent policy changes to the Shavlik Protect Cloud server.

    PolicyAgentKey3.JPG

    NOTE: Once you have clicked Force full update now you should see A full update has been requested. Examine 'Event history' to see the result pop up on the Operations Monitor.

     

    2) Navigate to View > Event History. Drop down the "Protect Cloud Sync Events" under the Event Type column and select your most recent date/time stamp with the "Full policy sync to the Protect Cloud" under the Name column.

    NOTE: Make sure all steps in the even history below show successful. If they do not, make sure that you can access the protectcloud.shavlik.com site from the console before proceeding.

     

    PolicyAgentKey4.JPG

    3) On the Shavlik Protect Cloud Website, refresh the Agent Key tab and select "New" button and verify that you can see the Protect Cloud Policy from the drop-down menu now.

    PolicyAgentKey5.png

     

    4) Finish creating the Agent Key and select "Create Key" to complete setup.

     

    Additional Information

     

    Make sure that you are also selecting the correct Protect console that created the Protect Cloud Agent Policy associated with the issue.

     

    Affected Product(s)


    Protect 9.X