Deployment Failures After Upgrading to Protect 9.2 - Patches Not Installed - Deployment Tracker Stuck at Scheduled

Version 13

    Purpose


    The purpose of this document is to explain a known Microsoft Scheduler issue in Protect 9.2 that is causing deployments to fail.


    Symptoms

     

    When you run a deployment as, "install immediately" between 6PM - 12AM local time, deployments are stuck at scheduled and no patches are installed.

    • install immediately.PNG

     

    When you schedule a scan with Auto-Deploy between 6PM - 12AM local time, deployments are stuck at scheduled and no patches are installed.

    scan with auto deploy.PNG


    The identifying errors can be found on the target machine in C:\Windows\ProPatches\Scheduler:

    When you look in the Scheduler.log, you see the following:

     

    Scheduler.cpp:294 CreateTrigger task exception: class STWin32::CWin32Exception at DateTime.cpp:547: Error 87: The parameter is incorrect..

    Scheduler.cpp:486 Not scheduling with AT seeing as the Scheduler 2.0 interface exists.

    AlternateScheduler.cpp:147 Failed to schedule job type immediate

    Cause


    There is a defect in Protect 9.2.5046 which prevents scheduling with the Microsoft Scheduler between 6PM - 12AM local time.


    • Customers who are specifically using the Microsoft Scheduler in Tools > Options > Scheduling will encounter this error.
    • Customers who are using the Shavlik Scheduler could also encounter this issue if the Shavlik Scheduler fails and Protect attempts to failover to the Microsoft Scheduler.

     

    Resolution


      This has been corrected with XML 2.0.1.8012 which was released on 03/31/2016. Please update your data files by going to Help > Refresh Files. Once the Refresh Files is complete, go to Help > About Shavlik Protect and verify that your data files are at least 2.0.1.8012.

     

    Affected Product(s)


    Shavlik Protect 9.2.5046