Protect Console Upgrade Fails With Errors 1603 or 1605

Version 8

    Purpose

    The purpose of this article is to troubleshoot the error one receives when trying to update the Protect Console from an older version to the latest version.

     

    Symptoms

     

    You attempt to upgrade your Protect console, the upgrade errors out and rolls back the upgrade.  The identify error 1603 and 1605 will be in the logs.


    1603 Error:

    "There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor."


    In the Shavlik Protect Installer GUI, you will see an error that states the following:

     

    2014-10-29_9-03-20.png

     

    From ProtectInstall log in C:\Users\(LoggedinUsername)\Appdata\Local\Temp folder:

     

    MSI (s) (94:20) [13:12:08:412]: MainEngineThread is returning 1603

     

    1605 Error:

    "This action is only valid for products that are currently installed.

     

    In the Shavlik Protect Setup GUI, you will see an error that states the following:

     

    Shavlik_Install_Error[1].jpg

    From ProtectSetup log in C:\Users\(LoggedinUsername)\Appdata\Local\Temp folder:


    ProtectSetup.cpp:369 Installation failed: class STWin32::CWin32Exception at Upgrade7x.cpp:351: Error 1605: This action is only valid for products that are currently installed..

     

    Cause

     

    There could be several causes for the errors to occur. The most likely causes are due to the following:

     

    1) Leftover registry information from a previous install. To resolve those issues, please consult the following article: Install - Uninstall Failures - How To Clean Up Broken Installs Of Shavlik Protect With The Microsoft Fixit Tool

     

    Before proceeding with the rest of this article, you should follow the steps in the above article to make sure things are properly uninstalled. Failure to do so could corrupt the console system.  If, after following the above article, you are still experiencing the same issues, you may proceed below.


    2) An ST Root Authority certificate is still installed on either the local user or the computer accounts' stores has not been deleted. To resolve these issues, please follow the steps below.

     

    Resolution

     

    1) Under Start > Run (or Windows Key + R) and type the following to bring up the Microsoft Management Console: mmc.exe

    NOTE: When Run is up, you can also type the following to bring up Certificate Manager and then proceed to Step 3 below: certmgr.msc

     

    1603error.JPG

     

    2) Navigate to File > Add or Remove Snap-in (or Ctrl+M) and select 'Certificates' in the Available snap-ins left-window pane and click 'Add >" in the middle.

     

    1603error2.JPG

     

    3) This will bring up another window with options to choose from. Select the My user account option and click Next. Click OK. You should now see Certificates listed under Console Root. Expand Certificates. Delete these certificates that are listed as being issued by ST Root Authority:

    • Personal > Certificates
    • Trusted Root Certification Authorities > Certificates
    • Intermediate Certification Authorities > Certificates

     

    1603error3.JPG

     

     

    You may need to also check the Computer Account certificates. To do so, repeat Steps 1-3 and instead of selecting the My user account option

     

        Select Computer account option and click Next. Ensure that the Local Computer option is selected and then click Finish. Click OK. Expand Certificates. Delete these certificates that are listed as being issued by ST Root Authority:

    • Personal > Certificates
    • Trusted Root Certification Authorities > Certificates
    • Intermediate Certification Authorities > Certificates

     

    1603error4.JPG

     

    4) Close the MMC window.  At this point, install the latest version of Protect.

     

    Additional Information

    It is highly recommended either making a backup of the machine or taking a snapshot of the VM in case anything gets corrupted in the process.

    Affected Product(s)

     

    Shavlik Protect 9.x