Search for recently released patches returns No Items in View > Patches

Version 4

    Purpose

     

    The purpose of this article is to troubleshoot why one would not see a patch in Patch View that has been added to the Shavlik Protect/Ivanti Patch for Windows Servers XML after refreshing the data files.

     

    Symptoms

     

    Searching for the patch by QNumber or Bulletin ID results in the patch not being listed even though it shows in the Shavlik Protect News Feed as being added with the latest XML's new content.

    The dialog box will also displa:

    There are no items to show in this view. Either the products selected have no patches available or your search criteria did not find anything.

     

    Cause

     

    The Local AppData XML files are being cached and are not properly loading when Patch View (View > Patches) is opened.

     

    Resolution

     

    1) Navigate to Help > Refresh Files to make sure everything downloads properly.

    2) Once the Refresh Files dialog is finished with no errors. Close out of the Shavlik Protect Console.

    3) Re-open the Shavlik Protect Console.

    4) Navigate to View > Patches.

    5) Make sure all Patch Properties are checked in the upper-left hand corner of Patch View under 'Patch Type'.

    6) Make sure the Smart Filter is set to *All Patches.

    7) Make sure All 'Vendors and Families' are checked in the lower-left hand corner of Patch View.

    8) Type in the QNumber into the Search bar (QNumber will be the same as the KB number of a Microsoft patch).

     

    patchview.JPG

     

    Additional Information

     

    If you are still unable to find the patch, please open a case with our Technical Support team by visiting support.ivanti.com.

     

    Affected Product(s)

     

    Shavlik Protect 9.x

    Ivanti Patch for Windows Servers 9.3.x