Scripted Agent Install May Fail During Registration Due To NetBIOS Resolution Failure

Version 2

    Overview

     

    You are attempting to install an agent using the Manual Installation Script and the agent fails to register with the Protect Console.

     

    You identify the issue through the following errors:

    These logs are located on the client machine: C:\ProgramData\LANDesk\Shavlik Protect\Logs

     

    Registration.log:

    Agent Registration Operation Log.

    Created Monday, January 01, 2015 01:01:01AM

    Error: Agent registration failed.

     

    STAgentManagement.log:

    An cookie is required to be passed in

     

    Cause


    You are using the NetBIOS name of the Protect server in the install script, but name resolution from the client machine to the Protect server fails using NetBIOS.


    STPlatformUpdater.exe /wi:"/qn /l*v install.log SERVERURI=https://ProtectServer:3121 POLICY=AV AUTHENTICATIONTYPE=PASSPHRASE PASSPHRASE=PASSPHRASE”


    Resolution


    • Correct the NetBIOS resolution issue from the client machine to the Protect server.
    • Use the FQDN of the Protect server instead of NetBIOS.
    • Use the IP Address of the Protect server instead of NetBIOS.


    Affected Product(s)


    Shavlik Protect 9.x