Smart Filter Based on Threat Definition Age May Not Show Expected Results

Version 3

    Symptoms

    Using a custom smart filter with the following settings in View > Machines, you see inconsistencies in the expected results.

     

    Smart Filter 1:

    Threat Definition Age - is greater than - 1

     

    Smart Filter 2:

    Threat Definition Age - is greater than - 7

     

    The first smart filter may come out appearing to provide correct results, however, any higher value may start to show inconsistent results.

     

    Cause

     

    The problem here is caused because our antivirus vendor does not provide a time in a format Protect can convert correct to date/time. Protect uses UTC for tracking these times, but because of the limitation Protect can be off by up to a day on the actual threat definition age. This in turn causes the filters to work inconsistently.

     

    Resolution

     

    Our engineering team does have this issue marked as a defect and hopes to fix in a future release. (Currently no ETA)

     

    Workaround:

    The best workaround is to sort the results within View > Machines by the 'Threat Definition Age' column instead of using Smart filters (Smart Filters set to *All machines).

     

    Example:

    Untitled.jpg

     

    Additional Information

     

    The column 'Threat Definition Age' may not be listed by default. You can add it or manipulate the view using the steps provided in the help documentation here:

    Customizing the Column Headers

     

    Affected Product(s)

     

    Shavlik Protect 9.1.4511

    Shavlik Protect 9.0.1221