Updates Published Using Shavlik Patch Are Not Showing up in 'All Software Updates'

Version 8

    Symptoms

     

    1) Updates published using Shavlik Patch are not showing up in 'All Software Updates' within the Configration Manager console.

     

    2) When you are about to publish updates via Shavlik Patch, you see a message listed; "Some of the selected updates may not synchronize."

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    'Click for details' will show a list of updates you are attempting to publish that 'may not synchronize with the current Software Update Point configuration.'

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    Cause

     

    There are two possible causes.

     

    1) You have not performed synchronization with the WSUS server.

     

    2) In System Center 2012 R2 Configuration Manager you need to update your Software Update Point to ensure you're syncing required vendors and locally published packages.

     

    Resolution

     

    There are two possible resolutions.

     

    1) You need to ensure you've successfully performed synchronization with the WSUS server.

     

    You may just need to perform the sync, or there may be a problem during the synchronization process that is causing the failure.

     

    Refer to the wsyncmgr.log from C:\Program Files\Microsoft Configuration Manager\Logs.

     

    Log on to the WSUS server, go to Admin Tools > Windows Server Update Services. Expand the WSUS server, then click on Synchronizations. You should be able to see a history of synchronizations here. (It may take quite some time to load.)

     

    2) In System Center 2012 R2 Configuration Manager you need to update your Software Update Point to ensure you're syncing required vendors and locally published packages.

     

    To check this:

     

    • Within the System Center Configuration Manager console:
      • Go to Administration
      • Expand Site Configuration
        • Click Sites
        • Right click on your primary site > Configure Site Components > Software Update Point
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      • Go to the Products tab.
        • Ensure to put a tick next to any newly added products and Local Publisher.
        • While in here it's worth double checking what you have set up under Classifications, Languages, Sync Settings, and Sync schedule as well.
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        • Perform synchronization with WSUS again.

     

    Additional Information

     

    See the following Microsoft articles for additional information about SUP (Software Update Point):

     

    About the Software Update Point

     

    How to Configure the Software Update Point

     

    Affected Product(s)

     

    Shavlik Patch for Microsoft System Center

    (Formerly SCUPdates)