Asset Scan Fails With - Cannot Connect To WMI Service. It Might Be Stopped Or Firewalled.

Version 8

    Symptoms

     

    Error Message while attempting a asset scan:


    [Machine Name] Cannot connect to WMI Service. It might be stopped or firewalled.

     

    Cause

     

    • Windows Management Instrumentation (WMI) service is Disabled/Off.
    • The necessary ports for an Asset scan are not accessible from the Protect Console to the Target Workstation.
    • The Protect Console cannot perform proper DNS resolution to the target workstation.
    • The DNS server contains multiple reverse lookup entries for the same IP Address

     

    Resolution

     

    • WMI Services must be started for hardware asset scanning.
    • Make sure IP Addresses are unique for target workstations in both the forward and reverse DNS Domain lookup
    • When performing an asset scan, Windows Management Instrumentation (WMI) service must be enabled on the target machine and the protocol allowed to the machine (TCP port 135).
    • In addition to the WMI port, other ports are necessary for an Asset scan to work properly.  Refer to the following document, Port Requirement for Shavlik Protect: http://community.shavlik.com/docs/DOC-2161

     

    Affected Product(s)


    Protect Version: All