Scan Results Fail to Import into Shavlik Protect

Version 5

    Symptoms


    • Scan results fail to import.
    • The operations monitor stops at step '5. Wait for results'.
    • STProtect.managed log contains the following line:

      DB connection issue error " E APAlertEventProducer.Create|Unable to connect to SQL Server 'xxx'. SqlError message: 'Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

     

    Cause


    This error occurs when the Protect services are configured to connect to a remote SQL database using Integrated Windows Authentication, and Kerberos is not working correctly within the environment. Using Integrated Windows Authentication with remote databases requires Kerberos. 

     

    Resolution


    To resolve this issue, you must correctly configure Kerberos within the environment. If Kerberos cannot be correctly implemented within the environment, configure Protect to connect using either Specific Windows User or SQL Authentication:

    1. Go to Start and select Database Setup Tool from the Shavlik NetChk Protect or VMware vCenter Protect program group.
    2. Select Use an existing database (link or upgrade).
    3. Click Next.
    4. Select the desired authentication method (for example, Specific Windows User or SQL Authentication).
    5. Enter a username and password with Administrative permissions to both the SQL database and the Protect console machine.

      Note: If specifying a domain user, preface the user name with the domain name followed by a backslash ('\').

    6. Click Test database connection to confirm adequate permissions.
    7. Complete the Database Setup Tool wizard.

     

    Affected Product(s)

     

    Shavlik Protect 9.x