Scheduling Deployments Fails With Error 1385

Version 4

    Symptoms

     

    • Cannot schedule deployments in Protect
    • Scheduling deployments fail with Error 1385 (this error may also appear in application logs)
    • This issue does not always occur on all targets

     

    Cause

     

    This issue occurs if Logon as Batch Job is not enabled for the user.

     

    Resolution

     

    To resolve this issue:

     

    1. Navigate to Control Panel > Admin Tools > Local Security Policy > Local Policies > User Rights Assignments.
    2. Ensure that the scheduling user is listed in the Log on as Batch Job user list.
    This security setting allows a user to be logged in using a batch queue facility and is provided for compatibility with older Windows versions. For example, when a user submits a job using the task scheduler, the task scheduler logs in that user as a batch user, rather than as an interactive user.

    Affected Product(s)

     

    Shavlik Protect All Versions